Angolo di cielo

registrato su http://www.siticattolici.it/ e su http://www.noicattolici.it/







Tutti gli orari sono UTC + 1 ora [ ora legale ]

Accedi alla Versione Mobile



Apri un nuovo argomento Rispondi all’argomento  [ 29 messaggi ]  Vai alla pagina Precedente  1, 2, 3, 4, 5, 6  Prossimo
Autore Messaggio
 Oggetto del messaggio: Problemi nel trasferimento del forum da remoto a locale
MessaggioInviato: martedì 28 giugno 2011, 21:31 
Non connesso
Provetto del Forum
Provetto del Forum

Iscritto: giovedì 26 maggio 2011, 16:22
Messaggi: 76
Località: Roma
Volevo, se possibile, ulteriori info per quanto riguarda lo spostare il proprio forum da remoto a locale con la MOD SEO già attiva. In pratica ero riuscito a portare il mio forum da remoto a locale: solo che poi, dopo l'installazione della SEO nel mio forum remoto, ho cambiato stile e ho installato una chat (mchat 1.3.5) e non so perché ho avuto la brillante idea di togliere le cartelle del vecchio forum locale, cancellare le cartelle del database locale, e rimettere le query con il metodo da te indicato, cioè del database splitterato. Poi ho messo i file e le cartelle del remoto nuove, però mi sono dimenticato di andare immediatamente nel PCA del forum locale, per cambiare indirizzo del server e dei cookie: in pratica l'ho fatto dopo 30 minuti: il risultato? L'ho indicato su www.phpbbitalia.net/forum/forum-di-supporto-f4/aiuto-per-favore-t4459.html. Dato che ora ho urgente bisogno di avere il forum in locale, quale è stata la causa? Il non andare subito nel PCA per modificare gli indirizzi? E quanto tempo si ha una volta inserite le query e aver copiato il forum, per cambiare gli indirizzi nel PCA?


Top
 Profilo  
Condividi su Google+Condividi su TwitterCondividi su FacebookCondividi su FriendFeedCondividi su SonicoCondividi su DiggCondividi su RedditCondividi su DeliciousCondividi su TumblrCondividi su MySpace  Segnala argomento
 

 Oggetto del messaggio: Problemi nel trasferimento del forum da remoto a locale
MessaggioInviato: martedì 28 giugno 2011, 22:45 
Non connesso
Moderatore
Moderatore
Avatar utente

Iscritto: lunedì 6 ottobre 2008, 15:59
Messaggi: 4145
Sito web: Visita
Devi sì occuparti delle voci cookie e server, che devono essere configurate immediatamente, come prima cosa; non c'è un tempo, ma è la prima cosa che si deve fare. Anzi, se non ricordo male, ti si era suggerito già di modificare tali voci anche prima dell'importazione del database. Generato il database, lo decomprimi, lo apri con il notepad++, e con la funzione trova e sostituisci del citato software, trovi l'attuale nome dominio, e sostituisci tutte le voci del dominio remoto con un'unica azione con localhost.
Fin qui il phpbb3 puro.
Nel caso della SEO, devi aggiungere, la configurazione locale del file .htaccess, e la generazione di una cache locale SEO, e ovviamente, la cancellazione della cache precedente, in riferimento al phpBB3.
In breve, non appena loggato, posto che le voci cookie e server siano già corrette (avendole tu corrette prima dell'importazione del database), devi assicurarti che non ci sia nessun file .htaccess, che la cache della SEO sia vuota, e generare in locale, un nuovo file .htaccess, dando le medesime impostazioni che hai in remoto.
A quel punto, avrai un file .htaccess remoto corretto per il locale, che potrai utilizzare anche in altri spostamenti (in locale). Tenendo presente che non devi occuparti solo del file .htaccess, da spostare nella root, ma di tutto il contenuto della cache della SEO.
In breve, tu ti sei occupato solo dei parametri del phpBB3 puro, ma hai del tutto trascurato il file .htaccess, e la cache della SEO, che devono essere appositamente generati per il locale. (Per fare un discorso veramente serio). Almeno la prima volta. Ed è fondamentale, che i parametri siano esattamente gli stessi. Come detto più volte, la precisione, è assolutamente fondamentale.

_________________
Il Venerabile Beda

Immagine

Noi, siamo sfacciatamente di parte, e ce ne vantiamo!

****

Immagine

Angolo di cielo, link ufficiale: http://angolodicielo.altervista.org


Top
 Profilo  
Condividi su Google+Condividi su TwitterCondividi su FacebookCondividi su FriendFeedCondividi su SonicoCondividi su DiggCondividi su RedditCondividi su DeliciousCondividi su TumblrCondividi su MySpace  Segnala argomento
 

 Oggetto del messaggio: Problemi nel trasferimento del forum da remoto a locale
MessaggioInviato: martedì 28 giugno 2011, 23:18 
Non connesso
Provetto del Forum
Provetto del Forum

Iscritto: giovedì 26 maggio 2011, 16:22
Messaggi: 76
Località: Roma
Beda, da te solo istruzioni dettagliate, sei veramente molto tecnico e preparato...
Cita:
devi assicurarti che non ci sia nessun file .htaccess, che la cache della SEO sia vuota, e generare in locale, un nuovo file .htaccess, dando le medesime impostazioni che hai in remoto.


Cioè una volta che sono nel PCA (loggato in locale) cancello il file .htaccess dalla root, cancello la cache della root, cancello la cache della SEO e poi imposto e creo il file .htaccess nuovo, dico bene? (Avevi ragione, ora ho modificato il file sql; c'erano le due voci nella struttura config da modificare).


Top
 Profilo  
Condividi su Google+Condividi su TwitterCondividi su FacebookCondividi su FriendFeedCondividi su SonicoCondividi su DiggCondividi su RedditCondividi su DeliciousCondividi su TumblrCondividi su MySpace  Segnala argomento
 

 Oggetto del messaggio: Problemi nel trasferimento del forum da remoto a locale
MessaggioInviato: martedì 28 giugno 2011, 23:53 
Non connesso
Moderatore
Moderatore
Avatar utente

Iscritto: lunedì 6 ottobre 2008, 15:59
Messaggi: 4145
Sito web: Visita
Io ho detto che la ricerca deve essere fatta automaticamente con la funzione trova e sostituisci del notepad++. Se diciamo una cosa, in quel modo si deve eseguire. Non in un modo che si avvicina. Precisione assoluta. Mi spiego? E se dico notepad++, deve essere notepad++, che è diverso dal notepad. Devi eseguire alla lettera, senza togliere una virgola, e senza aggiungerne una. Anche perché, nel caso della SEO, ci sono altre voci interessate. Senza contare, che se attui una ricerca manuale, potresti modificare le voci non necessarie, tralasciando quelle che devono essere sostituite.
Tutto automatico. Trova e sostituisci.


Quanto al resto, prima svuoti tutte le cache, ed elimini tutti i file .htaccess, e dopo ti logghi sul PCA, per generare un nuovo file .htaccess, come se fosse la prima installazione. Ribadisco, con i medesimi parametri. Anche qui, precisione. Non un solo parametro diverso da quello che hai in remoto. E ovviamente, appena loggato, la prima cosa da fare è andare sul PCA, e configurare la SEO; non girare il forum, gli argomenti, ecc. Quello lo farai dopo.

_________________
Il Venerabile Beda

Immagine

Noi, siamo sfacciatamente di parte, e ce ne vantiamo!

****

Immagine

Angolo di cielo, link ufficiale: http://angolodicielo.altervista.org


Top
 Profilo  
Condividi su Google+Condividi su TwitterCondividi su FacebookCondividi su FriendFeedCondividi su SonicoCondividi su DiggCondividi su RedditCondividi su DeliciousCondividi su TumblrCondividi su MySpace  Segnala argomento
 

 Oggetto del messaggio: Problemi nel trasferimento del forum da remoto a locale
MessaggioInviato: mercoledì 29 giugno 2011, 22:56 
Non connesso
Provetto del Forum
Provetto del Forum

Iscritto: giovedì 26 maggio 2011, 16:22
Messaggi: 76
Località: Roma
Aggiornamento: ieri sera ho fatto tutti i passaggi, e con quella modifica al database sql tutto risulta funzionante; però appena loggato (in locale) sono andato immediatamente sul PCA, ho svuotato le cache della root e della SEO; ho cancellato tutti i file .htaccess che c'erano, cioè: in root, in seo/cache, in root/file, in root/includes; poi ho configurato la SEO con le medesime impostazioni che ho in remoto, ho generato il file .htaccess, l'ho copiato nella root; però ritornato nell'Indice ho trovato lo stile vecchio, relativo alla problematica di sabato, non quello nuovo che ho installato Domenica con la relativa chat: perché? (il backup ftp dei file e delle cartelle l'ho eseguito ieri sera).


Top
 Profilo  
Condividi su Google+Condividi su TwitterCondividi su FacebookCondividi su FriendFeedCondividi su SonicoCondividi su DiggCondividi su RedditCondividi su DeliciousCondividi su TumblrCondividi su MySpace  Segnala argomento
 

Visualizza ultimi messaggi:  Ordina per  
Apri un nuovo argomento Rispondi all’argomento  [ 29 messaggi ]  Vai alla pagina Precedente  1, 2, 3, 4, 5, 6  Prossimo

Tutti gli orari sono UTC + 1 ora [ ora legale ]


   Argomenti correlati   Risposte   Visite    Ultimo messaggio 
Non ci sono nuovi messaggi in questo argomento. Chiarimenti sulle Regole del forum

[ Vai alla pagina: 1, 2 ]

in Cristiani - Cattolici

5

263

sabato 17 gennaio 2015, 17:02

Venerabile Beda Vedi ultimo messaggio



Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite


Non puoi aprire nuovi argomenti
Non puoi rispondere negli argomenti
Non puoi modificare i tuoi messaggi
Non puoi cancellare i tuoi messaggi
Non puoi inviare allegati

Vai a:  

cron






Aggiungi http://angolodicielo.altervista.org ai Preferiti!

Blue Glow 2 designed by ChaosBurnt
Powered by phpBB ® Forum Software phpBB 3.0.12 © phpBB Group
phpBB SEO
Traduzione Italiana phpBBItalia.net basata su phpBB.it 2010
Modificato e aggiornato da Angolo di cielo • 2013

Accedi alla Versione Mobile
Pagina generata in: 0.028 secondi